re = /https\:\/\/s3\-(\w+)\.amazonaws\.com\/(\w+)\/(\w+)\/(\w+)$/
str = 'https://s3-region.amazonaws.com/bucket/env/key'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end