package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\s+(?<capture>.*?)\s+(?:-|\$)`)
var str = `applicationName SXe Staging GCAST-2 - startTime
applicationName HDS 2016 VIRTUAL DESKTOP TEST $S88-166 - startTime `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}