import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^http(?:s)?://(?:www\\.)?(?:[\\w-]+?\\.)?reddit.com(/r/|/user/)?(?(1)([\\w:\\.]{2,21}))(/comments/)?(?(3)(\\w{5,9})(?:/[\\w%\\\\\\\\-]+)?)?(?(4)/(\\w{3,9}))?/?(\\?)?(?(6)(\\S+))?(\\#)?(?(8)(\\S+))?$";
final String string = "https://www.reddit.com/r/WTF/comments/17j3sd/this_crawled_into_one_of_my_students_pool_and_she/c867wpi/#c867wpi\n\n"
+ "https://www.reddit.com/r/reddit.com/comments/17863/two_countries_one_booming_one_struggling_which/c13/\n\n\n"
+ "https://old.reddit.com/r/switcharoo/comments/u24xnc/bond_girl_vs_james_bond/j3g066i/\n\n"
+ "https://www.reddit.com/r/truetf2/comments/107nizk/what_makes_a_lot_of_the_configuration/";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}