$re = '/\b7\d*\b/m';
$str = '7
756
178
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);