$re = '/\d+-\d+-\d+/m';
$str = 'Bill date: 09-09-2018
Bill date: 10-01-2018';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);