import re
regex = re.compile(r"\bA1\w+\b", flags=re.MULTILINE)
test_str = ("\\\"glass_id\\\":\\\"A1324053BC04\\\"\n"
"\\\"glass_id\\\":\\\"A132500DAA04\\\"\n"
"\\\"glass_id\\\":\\\"A132602XBK04\\\"\n"
"\\\"glass_id\\\":\\\"A131M06UBG04\\\"\n"
"\\\"glass_id\\\":\\\"A132308RBC04\\\"\n"
"\\\"glass_id\\\":\\\"A132405PCJ04\\\"\n"
"\\\"glass_id\\\":\\\"A132405QBC04\\\"\n"
"\\\"glass_id\\\":\\\"A132500CAW04\\\"\n"
"\\\"glass_id\\\":\\\"A132S06DBR03\\\"")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")