package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\bKaufmann e.K.\b)`)
var str = `Kaufmann e.K.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}