$re = '/(?<=\{)\d+(?=\})|(?<=\[)\d+(?=\])|(?<=\()\d+(?=\))/m';
$str = '{123} {4567] (890)
{12}34{56}
[1]2(3]
{1[23]4}
{12(34)}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);