$re = '/(?<bquote_all>
(
^[ \t]*>[ \t]?
.+\n
(?<bquote_other>.+\n)*
\n*
)+
)/mx';
$str = '> foo
>
> > bar
>
> foo
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);