const regex = /(?s)(?:\G(?!^)|ABC)(?:(?!ABC).)*?\Kc\d+(?=.*?BCE)/gs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?s)(?:\\G(?!^)|ABC)(?:(?!ABC).)*?\\Kc\\d+(?=.*?BCE)', 'gs')
const str = `c x c x ABC c1 x c2 x c3 BCE c x c x`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}