# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?=.{8,30}$)(?=.*[A-Za-z\d])(?!([ -\/:-@[-`{-~À-ÿ])\1{4}).*$"
test_str = ("AABBCCDD\n"
"OK -- Match\n\n"
"aabbccdd\n"
"OK -- Match\n\n"
"11111111\n"
"OK -- Match\n\n"
"A1A1b2b2\n"
"OK -- Match\n\n"
"A@~D1dIo\n"
"OK -- Match\n\n"
"AAB BCC0\n"
"OK -- Match (1 special, it's okay)\n\n"
"AABBCC@@\n"
"OK -- Match (2 specials, it's okay)\n\n"
"AABB C \n"
"OK -- Match (3 specials, it's okay)\n\n"
"A@~` C:\n"
"OK -- Match (3 specials, it's okay)\n\n"
"AABB\n"
"OK -- Should't match and didn't match (Less than 8 symbols)\n\n"
"AABBCCDDEEFFGGHHIIJJKKLLMMNNOOPP\n"
"OK -- Should't match and didn't match (More than 30 symbols)\n\n"
"AA@@@@BB\n"
"ERROR ! -- Shouldn't match (4 specials, it's forbidden)\n\n"
"AAB B\n"
"ERROR ! -- Shouldn't match (4 specials, it's forbidden)\n\n"
"AABB@@@@\n"
"ERROR ! -- Shouldn't match (4 specials, it's forbidden)\n\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.