re = /\w+:(?:(?=\[)(?:(?=.*?\[(?!.*?\1)(.*\](?!.*\2).*))(?=.*?\](?!.*?\2)(.*)).)+?.*?(?=\1)[^\[]*(?=\2$)|\w+)/m
str = 'field1:1234,field2:[[1, 3],[3,4]], field3:[[1, 3],[3,4]]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end