$re = '/_.*?\K\d+(?=M$)/m';
$str = 'A1M_PRE
AC2_0M
GA3_30M
DE3_1H30M
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);