$re = '/_([^._]+).csv/m';
$str = 'Varying Concentration2_20190712-145158_Base Media.csv
Varying Concentration2_20190712-145158_250 g per l.csv';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);