$re = '/^(?:[01]?[0-9]|2[0-3])(?:[:][0-5]?[0-9]){1,2}(?:[ ][APap][Mm])?$/m';
$str = '11:12:59 AM
1:2:3 PM
1:22:30 pm
01:2:00 PM
1:3 PM
12:09:00 AM
1:4';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);