re = /(?=.*?(Apple))(?>.*?(Orange))/m
str = 'xxxxxApplexxxxxxxxxxOrange
xxxOrangexxxxxApplexxxxxxxxxx
xxxOrangexxxxxOrangexxxxxxxxxx
xxxApplexxxxxApplexxxxxxxxxx
xxxOrangexxxxxxxxxxxxxxx
xxxxxxxxApplexxxxxxxxxx
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end