#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[^\d\s]*(\d+)(?!.*\1)"
Local $sString = "I would like abc123 to match but not 123." & @CRLF & _
"ab12s should also match" & @CRLF & _
"Only number-words like 1234 should not match" & @CRLF & _
"Words containing same numbers like ab22s should not match" & @CRLF & _
"234 should not match" & @CRLF & _
"hel1lo2haha3hoho4" & @CRLF & _
"hel1lo2haha3hoho3"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")