package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)::([^.]*?)::`)
var str = `Ma chaine de ::caractè res:: dans laquelle je dois ::trouver:: le modèle je dois trouver: le modèle`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}