import re
regex = re.compile(r"(.*) (e:\d*) (k:.*) \((\d{3}/\d)\)$", flags=re.MULTILINE)
test_str = ("/home/Plugins/file1 e:222 k:dir (327/1)\n"
"/home/Plugins/file2 e:100 k:dir (326/1)\n"
"/home/tools/AMS Provider/file3.txt e:224 k:dir (127/1)\n"
"/home/account validator e:227 k:dir (247/1)")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")