re = /[&?]validVehicle=(?:.*?%3a){3}(.*?)%3a/i
str = 'mysite.com/resource?slk=121&ops=rewww&from=kld&to=aop&search=things&validVehicle=sdfdsdff-sdfdf-sddf%3AVX%3ALNCX%3A123456789%3AOPW%3ALO'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end