const regex = /(?<="\[)(.*?),(.*?)(?=\]")/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<="\\[)(.*?),(.*?)(?=\\]")', 'gm')
const str = `9315c4ce-a467-4d70-98dc-85d5c3b3cfd6,A1T-0032-0,LightPoint,LIMAL/AVENUE-13EME-TIRAILLEURS/,false,,,AVENUE 13EME TIRAILLEURS,LIMAL,1300,Belgique,[],Point,"[4.570720633,50.69253469]",,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,33,100000,2019-01-01T09:22:00.000Z,Philips-929001573506-SR-C133,,4000,4100,,2019-01-01T09:22:00.000Z,Lightwell,LUXIS SMALL,lum8,,,6,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,REW,7704578,15094,M4,1843,,4040,"0,2 - 0,7",25 - 77,0,425,Potelet,Aluminium,Enfoui,-,-,-,4X10,EXVB,,211595323,0,0,13 TIRAILLEUR,5820,LED,Philips,,,545108,Voirie,127,LED 24,33,"9,29002E+11",SR,C133,40,TCC,2019-01-01T09:22:00.000Z,faux,,,,lum8,Pas de contrôleur,"[{""key"":""1978-01-01T09:22:00.000Z"",""value"":""HPL 125""}]",,,,,,,,,,`;
const subst = `$1|$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);