$re = '/(\d{1})(\d{7})(\d{8})(\d{8})(\w{6})(\d{11})/m';
$str = '146666042020060220200602PMB00200000000000';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);