import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=\\S+@)([^<\\s]+@.*(?=[>\\]]))";
final String string = "Hello my Email Address is <foo.@hotmail.com> - Return foo@hotmail.com as Group1.\n"
+ "Hello my Email Address is [mailto: foo@hotmail.com] - Return foo@hotmail.com as Group2.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}