#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([0-9A-Fa-f]{2}[:-]){5}([0-9A-Fa-f]{2})$"
Local $sString = "11-D6-D4-D7-B0-80" & @CRLF & _
"B5-42-A1-A7-33-B1" & @CRLF & _
"8C-03-74-2B-C6-D1" & @CRLF & _
"B5-5E-20-CH-1D-E6" & @CRLF & _
"7F-83-86-B6-7A-93" & @CRLF & _
"31-CE-78-13-75-FF" & @CRLF & _
"E5-EF-62-80-46-BC" & @CRLF & _
"D8-G2-44-10-49-E8" & @CRLF & _
"C6-45-E2-C5-D8-B3" & @CRLF & _
"F2-CA-6C-77-C3-7D" & @CRLF & _
"05-A0-4F-8A-F9-71" & @CRLF & _
"82-7B-DZ-D5-06-DA" & @CRLF & _
"B8-9F-45-90-D9-B3" & @CRLF & _
"82-7B-D6-D5-06-DA" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")