$re = '/^"(?<theNumber>\d+)"/m';
$str = '"26201",7\\0
"123",7111\\0000';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);