// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"("[^\\"]*(?:\\.[^\\"]*)*")?\s+"#).unwrap();
let string = "\"word1 word2\" \"word3 word4\" word5 word6";
let substitution = "\\1&";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}