re = /\/Normativo\/([^\/]+)\//m
str = 'https://teste.teste.pt/sites/teste/Normativo/NormasDeProcedimentos'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end