$re = '/^(?:bb){1,}$|^b$/m';
$str = 'b
bb
bbbb
bbbbbb';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);