// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([_0-9a-zA-Z-]+\/)(wp-(content|admin|includes).*)").unwrap();
let string = "wp-content/plugins/example.php
subsite1/wp-content/plugins/example.php
subsite2/wp-content/plugins/example.php";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}