# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=[\>.*\s])Produktpartner"
test_str = ("Produktpartner\n"
"<p> Produktpartner </p>\n"
"<p>Produktpartner</p>\n"
"<h2>Produktpartner</h2>\n"
"<Produktpartner></Produktpartner>\n"
"<a href=\"#\" title=\"Produktpartner\">Test</a>\n"
"Produktpartner\n"
"<img class=\"collection-logos__logo\" alt=\"Aberdeen\" src=\"/fileadmin/user_upload/_partnerlogos/Produktpartner-1234.svg\"\n"
" width=\"300\" height=\"200\" title=\"\"/>\n"
"<div class=\"collection-logos__logo-wrapper\">\n"
" Produktpartner\n"
" <img class=\"collection-logos__logo\" alt=\"Augsburger\"\n"
" src=\"/fileadmin/user_upload/_partnerlogos/Produktpartner-34566.svg\" width=\"300\" height=\"200\" title=\"\"/>\n"
"</div>\n"
"<p>Lorem ipsum dolor sit amet, consetetur sadipscing elitr, sed diam nonumy eirmod tempor invidunt ut labore et dolore magna aliquyam erat, sed diam voluptua. At vero eos et accusam et justo duo dolores et ea rebum. Stet clita kasd gubergren, no sea takimata sanctus est Lorem Produktpartner dolor sit amet. Lorem ipsum dolor sit amet, consetetur sadipscing elitr, sed diam nonumy eirmod tempor invidunt ut labore et dolore magna aliquyam erat, sed diam voluptua. At vero eos et accusam et justo duo dolores et ea rebum. Stet clita kasd gubergren, no sea takimata sanctus est Lorem ipsum dolor sit amet.</p>")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.