package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\[\[([^|]+)\|([^]]+)\]\]`)
var str = `[[текст1|текст2]]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}