# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^[LNSE] .*(?:\n(?![LNSE] ).*)?"
test_str = ("L 065 00 24329 12313 244.0.15.55 252.9.11.90 02/25 08:05 00:00:44 0000 0000 \n"
" \n"
"N 066 00 23442 T000185 262.1.00.09 02/25 08:05 00:00:02 A 16630\n"
"& 0000 0000 \n"
"S 067 00 00984 T000134 02/25 08:06 00:00:02 A 61445\n"
"& 0000 0000 \n"
"S 068 00 T000002 29536 02/25 08:05 00:00:36 \n"
"& 0000 0000 1234567890XXXXXX \n"
"E 069 00 T000002 T000185 02/25 08:06 00:00:00 \n"
"& 0000 0000 1234567890XXXXXX\n"
"L 065 00 24329 12313 244.0.15.55 252.9.11.90 02/25 08:05 00:00:44 0000 0000 ")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.