re = /Area\[[^-]+-\s((?<optional>[^-]+)\s-)?(?<address>[^\]]+)/
str = 'Feb 14 14:44:18 exnet-01a.intechnologywifi.com local1 events: EventType[Area Change] MAC[00:B3:62:BE:8E:B7] Details: Area[SS1 - CCTV193 - Eastern Esplanade]
Feb 10 13:56:29 exnet-01a.intechnologywifi.com local1 events: EventType[Area Change] MAC[A4:E4:B8:6E:DD:D2] Details: Area[SS1 - Leigh On Sea Community Centre]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end