package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b([A-Za-z]{2,25})\b`)
var str = `Marie claude Bouraoui ds`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}