const regex = /^9?[\d]{4}-[\d]{4}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^9?[\\d]{4}-[\\d]{4}$', 'gm')
const str = `# 8 dígitos sem traço
12345678
92841742
83457854
# 9 dígitos sem traço
123457890
899879878
983457854
912345678
# 8 dígitos com traço
1234-5678
9284-1742
8345-7854
# 9 dígitos com traço
12345-7890
89987-9878
98345-7854
91234-5678`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}