re = /^\+?(?:\([0-9]{1,4})\)?[0-9]{2}(?:[. -]?[0-9]{2}){4}$/m
str = '+(33)0123456789'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end