re = /^\/([^\/]+\/[^\/]+)\/([^\/]+(?:\/[^\/]+)+)$/m
str = '/firstname/lastname/some/cool/name'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end