using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\w+\.((\[(?<number>\d+)\])|(?<number>\d+))\.\w+
";
string input = @"test.10.test
test.[10].test
test.10].test
test.[10.test";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}