$re = '/\w+(?=[[:blank:]])/m';
$str = 'Mary jo
Anh Thi';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);