use strict;
my $str = 'https://m.facebook.com/pagefdgname/posts/990086801384551/
https://mbasic.facebook.com/username/posts/990086801384551:b
https://www.facebook.com/username/activity/990086801384551rt
https://www.facebook.com/photo.php?fbid=990086801384551=?=works
https://mbasic.facebook.com/photos/990086801384551
https://www.facebook.com/permalink.php?story_fbid=990086801384551&?
https://www.facebook.com/questions/990086801384551/
https://www.facebook.com/page-name/videos/990086801384551/
https://www.facebook.com/username/videos/990086801384551/
http://business.facebook.com/watch/?v=990086801384551
https://www.facebook.com/video.php?id=990086801384551
https://www.facebook.com/video.php?v=990086801384551
https://www.facebook.com/sgsxdfg/photos/pb.104-958162837./990086801384551/
';
my $regex = qr/(?:https?:\/\/(?:www|m|mbasic|business)\.(?:facebook|fb)\.com\/)(?:photo(?:\.php|s)|permalink\.php|video\.php|media|watch\/|questions|notes|[^\/]+\/(?:activity|posts|videos|photos))[\/?](?:fbid=|story_fbid=|id=|b=|v=|)(?|([0-9]+)|[^\/]+\/(\d+))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}