using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\$organization\['(.1*?)";
string substitution = @"\$organization\['\U\1\E";
string input = @"<?php $view->extend('layout.html.php') ?>
<div class=""boxContainer contentContainer textContainer"">
<?php //echo $this->partial('common/notifications.phtml', 'default',
//array('messages' => $this->notificationMessages)); ?>
<?php echo $view->render(':scripts:common/notifications.html.php') ?>
<h2 class=""contentHeader""><span><?php echo $view['translator']->trans('om.organization.detail.heading', [], 'om');?></span></h2>
<div class=""detail"">
<!-- Organization -->
<?php if (!empty($organization['name'])): ?>
<div class=""fieldRow"">
<span class=""label""><?php echo $view['translator']->trans('om.organization.name', [], 'om');?><span data-igo-help-tooltip=""help.om.organization.name.tooltip""></span></span>
<span class=""field""><?php echo $view->escape($organization['name']);?></span>
</div>
<?php endif; ?>
<?php if (isset($organization['active'])): ?>
<div class=""fieldRow"">
<span class=""label""><?php echo $view['translator']->trans('om.organization.active', [], 'om');?><span data-igo-help-tooltip=""help.om.organization.active.tooltip""></span></span>
<span class=""field""><?php /* @fixme echo $this->stateImage($organization['active'] ? 'ACTIVE' : 'INACTIVE') .
' ' . $this->booleanMessage($organization['active']); */?></span>
</div>
<?php endif; ?>
<?php if (!empty($organization['type'])): ?>
<div class=""fieldRow"">
<span class=""label""><?php echo $view['translator']->trans('om.organization.type', [], 'om');?><span data-igo-help-tooltip=""help.om.organization.type.tooltip""></span></span>
<span class=""field""><?php echo $view->escape($view['translator']->trans('om.organization.type.' . $organization['type'], [], 'om')); ?></span>
</div>
<?php endif; ?>
<?php if (!empty($organization['ownerOrganizationId'])): ?>
<div class=""fieldRow"">
<span class=""label""><?php echo $view['translator']->trans('om.organization.ownerOrganization', [], 'om');?><span data-igo-help-tooltip=""help.om.organization.ownerOrganization.tooltip""></span></span>
<span class=""field"">
<?php // echo $this->entityReference('organization', $organization['ownerOrganizationId']); ?>
</span>
</div>
<?php endif; ?>
<?php if (!empty($childOrganizations)): ?>
<div class=""fieldRow"">
<span class=""label""><?php echo $view['translator']->trans('om.organization.childOrganizations', [], 'om');?><span data-igo-help-tooltip=""help.om.organization.childOrganizations.tooltip""></span></span>
<span class=""field"">
<?php for ($i = 0; $i < count($childOrganizations); $i++): ?>
<?php
echo $childOrganizations[$i]['name'];
?>
<?php if ($i < count($childOrganizations) -1 ): ?>, <?php endif; ?>
<?php endfor; ?>
</span>
</div>
<?php endif; ?>
<?php if (!empty($organization['countryIds'])): ?>
<div class=""fieldRow"">
<span class=""label""><?php echo $view['translator']->trans('om.organization.countryIds', [], 'om');?><span data-igo-help-tooltip=""help.om.organization.countryIds.tooltip""></span></span>
<span class=""field"">
<?php foreach ($organization['countryIds'] as $countryId): ?>
<?php // echo $view->escape($this->country($countryId)->getCountryName()); ?><br />
<?php endforeach; ?>
</span>
</div>
<?php endif; ?>
<?php if (!empty($organization['languageCodes'])): ?>
<div class=""fieldRow"">
<span class=""label""><?php echo $view['translator']->trans('om.organization.languageCodes', [], 'om');?><span data-igo-help-tooltip=""help.om.organization.languageCodes.tooltip""></span></span>
<span class=""field"">
<?php
for ($i = 0; $i < count($organization['languageCodes']); $i++) {
if (!empty($organization['languageCodes'][$i])) {
// echo $this->entityReference('language', trim($organization['languageCodes'][$i]));
if ($i !== count($organization['languageCodes']) - 1) {
echo ', ';
}
}
}
?>
</span>
</div>
<?php endif; ?>
<?php if (!empty($organization['roles'])):?>
<div class=""fieldRow"">
<span class=""label""><?php echo $view['translator']->trans('om.person.roles', [], 'om'); ?><span data-igo-help-tooltip=""help.om.organization.roles.tooltip""></span></span>
<span class=""field"">
<?php for ($i = 0; $i < count($organization['roles']); $i++) :?>
<?php echo $organization['roles'][$i]['name']; ?>
<?php if ($i < count($organization['roles']) -1): ?>, <?php endif; ?>
<?php endfor;?>
</span>
</div>
<?php endif;?>
<?php if ($organization['type'] === 'POS' & !empty($organization['flags'])): ?>
<?php foreach($organization['flags'] as $flag): ?>
<div class=""fieldRow"">
<span class=""label""><?php echo $view['translator']->trans('om.organization.' . $flag);?><span data-igo-help-tooltip=""help.om.organization.<?= $flag ?>.tooltip""></span></span>
<span class=""field"">Yes</span>
</div>
<?php endforeach; ?>
<?php endif; ?>
<?php if (!empty($organization['logotypeFilename'])): ?>
<div class=""fieldRow"">
<span class=""label""><?php echo $view['translator']->trans('image', [], 'om'); ?><span data-igo-help-tooltip=""help.om.organization.logotypeFilename.tooltip""></span></span>
<span class=""field"">
<?php if ($organization['logotypeFilename']): ?>
<img src=""<?php echo $view->escape($organization['logotypeFilename']); ?>""
alt=""<?php echo $view->escape($organization['name']); ?>""
title=""<?php echo $view->escape($organization['name']); ?>""/>
<?php endif; ?>
</span>
</div>
<?php endif; ?>
<?php if (!empty($organization['description'])): ?>
<div class=""fieldRow"">
<span class=""label""><?php echo $view['translator']->trans('om.organization.description', [], 'om');?><span data-igo-help-tooltip=""help.om.organization.description.tooltip""></span></span>
<span class=""field""><?php echo $view->escape($organization['description']);?></span>
</div>
<?php endif; ?>
<?php if (!empty($organization['customCardType'])): ?>
<div class=""fieldRow"">
<span class=""label""><?php echo $view['translator']->trans('om.organization.customCardType', [], 'om');?><span data-igo-help-tooltip=""help.om.organization.customCardType.tooltip""></span></span>
<span class=""field""><?php echo $view->escape($organization['customCardType']); ?></span>
</div>
<?php endif; ?>
<?php if (!empty($organization['contractStartDate'])): ?>
<div class=""fieldRow"">
<span class=""label""><?php echo $view['translator']->trans('om.organization.contractStartDate', [], 'om');?><span data-igo-help-tooltip=""help.om.organization.contractStartDate.tooltip""></span></span>
<span class=""field""><?php echo $organization['contractStartDate'];?></span>
</div>
<?php endif; ?>
<?php if (!empty($organization['contractEndDate'])): ?>
<div class=""fieldRow"">
<span class=""label""><?php echo $view['translator']->trans('om.organization.contractEndDate', [], 'om');?><span data-igo-help-tooltip=""help.om.organization.contractEndDate.tooltip""></span></span>
<span class=""field""><?php echo $organization['contractEndDate'];?></span>
</div>
<?php endif; ?>
<?php if (!empty($organization['mamutId'])): ?>
<div class=""fieldRow"">
<span class=""label""><?php echo $view['translator']->trans('om.organization.mamutId', [], 'om');?><span data-igo-help-tooltip=""help.om.organization.mamutId.tooltip""></span></span>
<span class=""field""><?php echo $organization['mamutId'];?></span>
</div>
<?php endif; ?>
<?php if (!empty($organization['contactEmail'])): ?>
<div class=""fieldRow"">
<span class=""label""><?php echo $view['translator']->trans('om.organization.contactEmail', [], 'om');?><span data-igo-help-tooltip=""help.om.organization.contactEmail.tooltip""></span></span>
<span class=""field""><?php echo $organization['contactEmail'];?></span>
</div>
<?php endif; ?>
<hr />
<!-- Contact attributes -->
<?php if (!empty($organization['address1'])): ?>
<div class=""fieldRow"">
<span class=""label""><?php echo $view['translator']->trans('om.organization.address1', [], 'om');?><span data-igo-help-tooltip=""help.om.organization.address1.tooltip""></span></span>
<span class=""field""><?php echo $view->escape($organization['address1']);?></span>
</div>
<?php endif; ?>
<?php if (!empty($organization['address2'])): ?>
<div class=""fieldRow"">
<span class=""label""><?php echo $view['translator']->trans('om.organization.address2', [], 'om');?><span data-igo-help-tooltip=""help.om.organization.address2.tooltip""></span></span>
<span class=""field""><?php echo $view->escape($organization['address2']);?></span>
</div>
<?php endif; ?>
<?php if (!empty($this->postalCode['cardType'])): ?>
<div class=""fieldRow"">
<span class=""label""><?php echo $view['translator']->trans('om.organization.postalCode', [], 'om');?><span data-igo-help-tooltip=""help.om.organization.postalCode.tooltip""></span></span>
<span class=""field""><?php echo $view->escape($organization['postalCode']);?></span>
</div>
<?php endif; ?>
<?php if (!empty($organization['cityGeoId'])): ?>
<div class=""fieldRow"">
<span class=""label""><?php echo $view['translator']->trans('om.organization.cityGeoId', [], 'om');?><span data-igo-help-tooltip=""help.om.organization.cityGeoId.tooltip""></span></span>
<span class=""field""><?php // echo $view->escape($this->city($organization['cityGeoId'])->getCityName());?></span>
</div>
<?php endif; ?>
<?php if (!empty($organization['phone'])): ?>
<div class=""fieldRow"">
<span class=""label""><?php echo $view['translator']->trans('om.organization.phone', [], 'om');?><span data-igo-help-tooltip=""help.om.organization.phone.tooltip""></span></span>
<span class=""field""><?php echo $view->escape($organization['phone']);?></span>
</div>
<?php endif; ?>
<?php if (!empty($organization['fax'])): ?>
<div class=""fieldRow"">
<span class=""label""><?php echo $view['translator']->trans('om.organization.fax', [], 'om');?><span data-igo-help-tooltip=""help.om.organization.fax.tooltip""></span></span>
<span class=""field""><?php echo $view->escape($organization['fax']);?></span>
</div>
<?php endif; ?>
<?php if (!empty($organization['email'])): ?>
<div class=""fieldRow"">
<span class=""label""><?php echo $view['translator']->trans('om.organization.email', [], 'om');?><span data-igo-help-tooltip=""help.om.organization.email.tooltip""></span></span>
<span class=""field""><?php echo $view->escape($organization['email']);?></span>
</div>
<?php endif; ?>
<!-- Operational attributes -->
<hr />
<?php if (!empty($organization['createdDate'])): ?>
<div class=""fieldRow"">
<span class=""label""><?php echo $view['translator']->trans('om.organization.createdDate', [], 'om');?><span data-igo-help-tooltip=""help.om.organization.createdDate.tooltip""></span></span>
<span class=""field""><?php echo $organization['createdDate'];?></span>
</div>
<?php endif; ?>
<?php if (!empty($organization['lastModifiedDate'])): ?>
<div class=""fieldRow"">
<span class=""label""><?php echo $view['translator']->trans('om.organization.lastModifiedDate', [], 'om');?><span data-igo-help-tooltip=""help.om.organization.lastModifiedDate.tooltip""></span></span>
<span class=""field""><?php echo $organization['lastModifiedDate'];?></span>
</div>
<?php endif; ?>
<?php if (!empty($organization['lastModifiedByUserId'])): ?>
<div class=""fieldRow"">
<span class=""label""><?php echo $view['translator']->trans('lastModifiedByUser', [], 'common'); ?><span data-igo-help-tooltip=""help.om.organization.lastModifiedByUser.tooltip""></span></span>
<span class=""field"">
<?php // echo $this->entityReference('user', $organization['lastModifiedByUserId']); ?>
</span>
</div>
<?php endif; ?>
<!-- Additional organization info -->
<?php if (!empty($organization['websites']) ||
!empty($organization['twitterLink']) ||
!empty($organization['facebookLink']) ||
!empty($organization['studentPopulation']) ||
!empty($organization['cardRetailSellingPrice'])): ?>
<hr />
<?php endif; ?>
<?php if (!empty($organizationWebsites)): ?>
<div class=""fieldRow"">
<span class=""label""><?php echo $view['translator']->trans('om.organization.website', [], 'om'); ?><span data-igo-help-tooltip=""help.om.organization.website.tooltip""></span></span>
<span class=""field"">
<?php for ($i = 0; $i < $websitesCount = count($organizationWebsites); $i++) :?>
<a href=""<?php echo $organizationWebsites[$i]; ?>"" target=""_blank""><?php echo $organizationWebsites[$i]; ?></a>
<?php if ($i != $websitesCount - 1) {
echo("", "");
} ?>
<?php endfor;?>
</div>
<?php endif; ?>
<?php if (!empty($organization['twitterLink'])): ?>
<div class=""fieldRow"">
<span class=""label""><?php echo $view['translator']->trans('om.organization.twitterLink', [], 'om'); ?><span data-igo-help-tooltip=""help.om.organization.twitterLink.tooltip""></span></span>
<span class=""field""><a href=""<?php echo $organization['twitterLink'];?>"" target=""_blank""><?php echo $organization['twitterLink'];?></a></span>
</div>
<?php endif; ?>
<?php if (!empty($organization['facebookLink'])): ?>
<div class=""fieldRow"">
<span class=""label""><?php echo $view['translator']->trans('om.organization.facebookLink', [], 'om'); ?><span data-igo-help-tooltip=""help.om.organization.facebookLink.tooltip""></span></span>
<span class=""field""><a href=""<?php echo $organization['facebookLink'];?>"" target=""_blank""><?php echo $organization['facebookLink'];?></a></span>
</div>
<?php endif; ?>
<?php if (!empty($organization['studentPopulation'])): ?>
<div class=""fieldRow"">
<span class=""label""><?php echo $view['translator']->trans('om.organization.studentPopulation', [], 'om'); ?><span data-igo-help-tooltip=""help.om.organization.studentPopulation.tooltip""></span></span>
<span class=""field""><?php echo $organization['studentPopulation'];?></span>
</div>
<?php endif; ?>
<?php if (!empty($organization['cardRetailSellingPrice'])): ?>
<div class=""fieldRow"">
<span class=""label""><?php echo $view['translator']->trans('om.organization.cardRetailSellingPrice', [], 'om'); ?><span data-igo-help-tooltip=""help.om.organization.cardRetailSellingPrice.tooltip""></span></span>
<span class=""field""><?php echo $organization['cardRetailSellingPrice'];?></span>
</div>
<?php endif; ?>
</div>
</div>
<?php if (Default_Model_SecurityUtils::hasPermission('ROLE_OM_ORGANIZATION_READ')): ?>
<div class=""pageControls"">
<div class=""left"">
<?php // @FIXME $defaultBackUrl = $this->url(array('controller' => 'organizations', 'action' => 'search', 'module' => 'om'), 'default'); ?>
<a class=""btn btn-link"" href=""<?php // echo $this->backUrl($defaultBackUrl); ?>""><?php echo $view['translator']->trans('back', [], 'common'); ?></a>
</div>
<div class=""right"">
<?php
// @FIXME $targetUrl = $this->url(array('action' => 'edit', 'id' => $organization['organizationId']), 'resource');
?>
<?php //@FIXME echo $this->renderButton('edit', array('style' => 'wlw', 'align' => 'right',
//'href' => $this->backUrlAppend($targetUrl))); ?>
</div>
<div class=""clearer""></div>
</div>
<?php endif; ?>
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}