$re = '/^[a-zA-Z](?=.{5,15}$)[^-]*(?:-[^-]+)?$/m';
$str = 'Ayy7789-kkk';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);