#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\$[0-9]{1,3}(\.[0-9]{2})?(?![0-9.])"
Local $sString = "I have $400 in my bank account." & @CRLF & _
"This TV costs $300" & @CRLF & _
"This TV costs $300." & @CRLF & _
"" & @CRLF & _
""$45.3242" or "3499,391""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")