import re
regex = re.compile(r"\baş", flags=re.MULTILINE)
test_str = ("YEmreAk.com sitesinden buraya gelmiş bulunmaktasın. \n\n"
"Bu bir deneme metnidir. RegEx testleri yapmak için yazılmıştır\n\n"
"Sağ üstteki 🔍 Arama Buton'nu kullanmayı asla asla ihmal etme\n"
"En son gelen güncellemeleri ✨ Commits alanından takip edebilirsin\n"
"Tavsiyelerin veya hata tespitlerin varsa 🦋 Issue açabilirsin\n"
"🌊 Yeni bilgiler öğrenmemle birlikle güncellenecektir\n"
"Yani hep güncel kalacak denebilir 🚀\n"
"İyi okumalar 👻\n"
"🚀 Awesome etiketi ile adlandırılan, bir konu veya yazılım üzerine detaylı açıklamaların yapıldığı projelere bakmana fayda var\n"
"🚙 Diğer Özenle Hazırladığım Notlar\n"
"Veri yığılmasını 📚 engellemek için içeriği fazla olan 📈 bilgiler farklı repository'lere aktarıldı.\n"
"Yapay Zeka Notlarım\n"
"İstanbul Üniversitesi - Bilgisayar Mühendisliği Notları\n"
"React ve Firebase projem\n"
"Sol alt köşedeki alandan da bunlara erişebilirsin ✨\n"
"🔗 Harici Bağlantılar\n"
"Alibaba Cloud for Students\n"
"The Best Font for Resume\n"
"Yaratıcı Fikirler için Tasarımlar\n"
"Açık API listesi\n"
"Türkçe Dökümanlar\n"
"✍ Çalışma Notları\n"
"Her şey dinamik olmalı\n"
"Önce sabit değerli yaz, sonrasında ✲ Ctrl + F ile sabitleri değişken haline dönüştür\n"
"Terimler italik\n"
"önemli notlar ve başlıklar bold\n"
"komutlar code\n"
"matematikler (latex) $latex$\n"
"butonlar ve tıklanabilir öğeler button\n"
"Akşam aşama")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")