$re = '/(\d*\.?\d+)(?:\(g\/\d*ml\)|g)?(?=,|$)/m';
$str = '0, 1, 0.1, .1, 1g, 0.1g, .1g, 1(g/100ml), .1(g/ml)
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);