using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=(?!(.)\1)([^\DO:105-93+30])(?-1)(?<!\d(?<=4))).[^\WHY?]$";
string input = @"┌──────────────────────────────┐
│ What is the Meaning of Life? │
│ Potential Answers │
└──────────────────────────────┘
Dear regex, please pick one of the following lines.
---
The meaning of life, according to the Oxford English Dictionary, is the condition or attribute of living or being alive.
Why should life have a meaning? What a stupid question.
42
Meaning of life has to be qualified. The meaning of your life to you is not the same as the meaning of your life to a dictator. And what about the meaning of a bee's life, or of a bacteria's life. In other words, see the two previous answers, which can be summarized by 'what a stupid question.'
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}