$re = '/^@[A-Za-z0-9._]+$/m';
$str = '@_._...
@___abc___
@abc.123_xyz
@abc';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);