const regex = /ALPHA(.*('BI_\d+'))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('ALPHA(.*(\'BI_\\d+\'))', 'g')
const str = `ALPHA;111,'BI_209'
ALPHA;222,'BI_213'
ALPHA;AAA,'BI_209'
ALPHA;FFF,'BI_209'
ALPHA;123,'BI_220'`;
const subst = `\2\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);