using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^'""\s]*dark:[^'""\s]*";
string input = @"<button class=""dark:text-white text-black"">My Button</button>
<button class=""text-black dark:text-white text-black"">My Button</button>
<button class=""text-black dark:text-white"">My Button</button>
<button class=""[&[data-test]]:dark:text-white text-black"">My Button</button>
<button class=""text-black [&[data-test]]:dark:text-white text-black"">My Button</button>
<button class=""text-black [&[data-test]]:dark:text-white"">My Button</button>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}