package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)\w*:\w*`)
var str = `blabla:test abcde 123test:123`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}